[GCC-XML]Wrong output in version 0.4.1?

Nicodemus nicodemus at globalite.com.br
Thu Feb 20 17:41:05 EST 2003

Hail all!

I'm running gccxml 0.4.1 on some files of the Visual Studio distribution, and I 
believe there is something wrong with the output.

  <Field id="_821" name="_Gr" access="private" type="_501" context="_0" 
   <Field id="_822" name="_Dp" access="private" type="_827" context="_0" 
   <Field id="_823" name="_Ks" access="private" type="_827" context="_0" 
[snipped some more lines similar]

The problem is the context: there's no context with the id "_0" in the rest of 
the file. Is this a bug?

The files are xlocale, xlocnum from $MSVCDIR/Include and vector, utility, 
ostream, istream from Vc6/Include of the gccxml distribution. I ran in the 
command line:
     gccxml %MSVCDIR/Include/xlocnum -fxml=out.xml

I was using the version 0.4.0 and didn't have this problem.

I have another question: how can I simulate the Intel C++ compiler? The homepage 
states that gccxml has support for it, and the name of the compiler must be 
passed to the --gccxml-compiler flag. I tried icl, intel, intelc++ and others 
without success. What's the correct name?

Another question: I would like to make gccxml use STLport instead of the default 
visual studio standard libraries. I pass the path to stlport with the -I flag, 
but gccxml apparently includes the vc libraries first by default. How can I 
change this behaviour?

Any help will be appreciated.


More information about the gccxml mailing list